Eine schwierige Fehlersuche

Es ist jetzt gleich halb drei in der Nacht, und ich habe lange nach einem blöden Fehlerr in meinem Blog gesucht. Aber ich bin zuversichtlich, ihn jetzt gefunden zu haben!

Wer klickt hin und wieder schon mal auf seinen eigenen RSS-Feed, um sich die codierung anzusehen? Kaum einer. Ich machte das heute mal, weil ich mich schon eine ganze Weile darüber wunderte, dass irgendwas mit meinem Blog blöd war, und auch darüber, dass es in blogg.de nicht mehr verlinkt wurde, wie noch am Anfang. Aber es war reiner Zufall, dass ich den Fehler entdeckte: „XML-Seite kann nicht angezeigt werden, wenn xsl-Stylesheet verwendet wird.“ Aber als Newbi, der ich nun mal bin, wusste ich überhaupt nicht, was das zu bedeuten hatte!

Ich habe alles mögliche angestellt. Ich befürchtete, es liege daran, dass ich externe Feeds in meine Seite einband, aber das war es auf keinen Fall. Dann dachte ich mir, es könnte ein Problem der Codierung sein. Ich habe die xml-Datei des RSS-Feeds runtergeladen, und ich habe in Foren geschmökert. Dabei fand ich zwar nichts zum Thema WordPress mit diesem Fehler, aber allgemein tritt der wohl dann auf, wenn unerlaubte Zeichen in der XML-Datei des RSS-Feeds sind. RSS, XMLFeed eines befreundeten Blogs, und fand dort dasselbe. Nur die Codierung war eine Andere, nämlich eine UTF-8, während ich noch ISO8859-1 verwende. War es das? Ich konnte es mir kaum vorstellen. Dann fiel mir auf, dass die Überschriften keine Umlaute enthielten. War das vielleicht das Problem?

Schließlich stellte ich fest, dass zwar der Teaser des befreundeten Blogs schön in HTML kommt, der Inhalt der einzelnen Beiträge aber nicht, sondern nur in UTF-8 codiert. Dann stellte ich mit einem Geistesblitz fest, dass ich seit einem bestimmten Zeitpunkt eine Blogging-Software verwende, vorher aber alles von Hand eingegeben habe. Könnte es daran liegen? Gut, das musste ich prüfen. In meiner Blogging-Software fand ich den Punkt: Umlaute convertieren? Den hatte ich aktiviert, jetzt deaktivierte ich ihn, und siehe da, bis jetzt ist mir noch kein Fehler wieder angezeigt worden. Die Feuertaufe allerdings muss das System noch bestehen. Drückt mir die Daumen. Auch wenn ich den Fehler behoben haben sollte, ist mir sein Grund immer noch nicht klar. Falls es jemand meiner geneigten LeserInnen weiß, wäre ich für einen kurzen Hinweis sehr dankbar.

Gute Nacht.

Copyright © 2005, Jens Bertrams.

Flattr this!

Über Jens Bertrams

Jahrgang 1969, Journalist bei www.ohrfunk.de, Fan der Niederlande und der SF-Serie Perry Rhodan.
Dieser Beitrag wurde unter Bloggen, Computer und Internet, Leben veröffentlicht. Setze ein Lesezeichen auf den Permalink.
Nach oben

Comments

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.